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Boson NetSim Overview
The Boson NetSim® Network Simulator®, which includes the Boson Router Simulator®, is unique compared to all 
others on the market because of the functionality it supports and its features. NetSim utilizes Boson’s proprietary 
Network Simulator, Router Simulator®, and EROUTER® software technologies, along with the Boson Virtual 
Packet Technology® engine, to create individual packets. These packets are routed and switched through the 
simulated network, allowing NetSim to build an appropriate virtual routing table and simulate true networking. 
Other simulation products on the market do not support this level of functionality.

NetSim is a Windows®-based product that simulates a wide variety of Cisco® routers, including the 2500 series, 
2600 series, 2800 series, and 3600 series routers, as well as the Cisco Catalyst 1900 series, 2900 series, and 
3500 series switches. NetSim supports multiple routing protocols, including RIP, IGRP, EIGRP, BGP, and OSPF. 
It supports different LAN/WAN protocols, including PPP/CHAP, ISDN, and Frame Relay. The labs in NetSim 
require only the devices and functionality included with NetSim—they do not require access to any external router 
or switch hardware. NetSim supports many, but not all, of the IOS commands available on a physical router or 
switch. All of the commands referenced in the available labs are supported by NetSim.

Achieving Cisco CCENT®, CCNA®, or CCNP® certification is the goal of many people who use this product. The 
Boson NetSim covers not only the SWITCH (300-115), TSHOOT (300-135), and ROUTE (300-101) certifications 
but also the ICND1 (100-105), ICND2 (200-105), and CCNA (200-125) certifications, among others. The included 
labs guide you through the configuration of routers, switches, and workstations in a variety of scenarios. Installed 
labs are made available (unlocked) depending on the activation key used to activate the product. All labs are 
downloaded and kept up to date after installation regardless of the activation key used; however, the only labs 
that are available are ones that have been unlocked with the associated activation keys. 

Activation keys unlock labs and increase the number of available commands. Beginning with the Demo version 
of NetSim 12, the command set is limited to those necessary to perform the steps in the lab. For example, if 
you start your studies with a CCENT activation key, you will have the command set and labs available that are 
necessary to study for that exam. When you are ready to study for either the CCNA or CCNP exam, you will need 
to purchase a new activation key and activate NetSim with the new CCNA or CCNP activation key; then, more 
labs and a larger command set become available. 

Some of the labs available in the Sequential lab pack when a CCENT activation key has been used to activate 
NetSim 12 are shown in the following graphic. A CCENT activation key also unlocks a selection of labs from 
the Stand-Alone and Scenario lab packs. A small lock icon ( ) is displayed next to unavailable labs. Higher-level 
activation keys allow you to work through all labs unlocked by lower-level activation keys. All demo, CCENT, 
CCNA, and CCNP labs are unlocked when a CCNP-level activation key is used. Some lab packs are delivered by 
NetSim to support other products that are sold separately. If you have questions about locked labs, please contact 
support@boson.com.

mailto:support@boson.com
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After you load and complete an unlocked lab, you can use the grading function in NetSim to grade the lab so that 
you can determine whether you completed it correctly. As you progress through the labs, you can master the skills 
needed to pass the simulation questions in the Cisco certification exams. NetSim has the ability to guide and 
grade, and using it for practice can be more helpful than using real routers and switches. NetSim allows you to 
gain experience without requiring you to purchase expensive equipment.

You can use the Boson NetSim to work through labs, but you can also use it for additional purposes. For example, 
you can create your own logical topology to practice designing and planning a network. This tool’s functionality 
goes beyond that of most tools because you can actually create the device configurations that are going to be 
used, save those configurations, and practice using them on simulated devices.

Routing protocol implementation is one of the more challenging tasks you might encounter. Troubleshooting a 
production network can be a frustrating experience. Fortunately, you can create a virtual copy of your network by 
creating a new topology in NetSim and troubleshoot the problems without interfering with your production network. 
Because NetSim is designed as a study tool for Cisco certification, you should not rely only on NetSim to make 
decisions about a production network, but you might find it useful in your troubleshooting efforts.

In summary, Boson NetSim is a flexible and powerful product that can help you become certified and, in some 
cases, it can be used to create a simulation of the topology of your corporate network and help you practice 
troubleshooting without using devices on the production network.



� Boson NetSim User Manual

Using NetSim to Prepare for Your Certification
By using NetSim to help you achieve a Cisco certification, you can learn and master the skills necessary to help 
you successfully complete your certification track. The purpose of NetSim is to help you with the practical, hands-
on portion of your education and to ensure that you not only understand the concepts of routing but can actually 
configure and implement routing on Cisco devices.

Mastering Cisco networking involves two fundamental tasks:

1. Learn the theory of routers and switches.
2. Gain the hands-on experience of implementing that theory by configuring the devices in a network and 

testing them in a lab.

Self-studying for a Cisco certification can be a daunting task. The amount of information a CCNA candidate is 
required to know and the skills that candidate is required to possess are quite extensive. To begin learning the 
theory of configuring a network, you can find a good reference book or listen to an instructor. (Boson Training, 
www.boson.com/boson-training, offers a full slate of classes and Bootcamps.) But a reference book might not be 
enough. The book will not give you the practical, hands-on experience of routing and switching that you can learn 
from NetSim—experience that will help you build on the theoretical knowledge you learned from the reference 
book.

Real equipment gives you the ability to practice on physical routers and switches, but it also is a very costly way 
to practice and leaves a lot of room for error. The Boson NetSim, on the other hand, is an excellent tool to help 
you prepare for the CCNA (www.boson.com/certification/CCNA) and CCNP  
(www.boson.com/certification/CCNP) exams. NetSim simulates the behavior of a network and does not just return 
preprogrammed responses to expected command inputs. It allows you to create virtual packets and virtual frames 
that will be routed and switched through the simulated network. Aside from physically plugging in the cables and 
listening to the fan noise, your experience with the simulated network will be much the same as your experience 
with a fully functional lab rack without the expense of the hardware. NetSim will enable you to practice various 
configurations and master helpful skills.

Once you feel you have mastered both the theory (www.boson.com/boson-training) and the practical labs  
(www.boson.com/netsim-cisco-network-simulator), you can test your knowledge by using the Boson ExSim-Max 
practice exam products available at the ExSim-Max home page (www.boson.com/exsim-max-practice-exams). 
Boson ExSim-Max products include complex multiple-choice questions, drag-and-drop questions, Boson NetSimX 
simulation questions, and trouble tickets.

The Boson NetSim Network Simulator is the most comprehensive product on the market for learning how to 
configure a Cisco router. The Boson NetSim will not only help you become certified, it will help you learn and 
understand how to configure routers, switches, and networks.

www.boson.com/boson-training
www.boson.com/certification/CCNA
www.boson.com/certification/CCNP
www.boson.com/boson-training
www.boson.com/netsim-cisco-network-simulator
www.boson.com/exsim-max-practice-exams
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Contact Information
EMAIL: support@boson.com
PHONE: 877-333-EXAM (3926)
 615-889-0121
FAX: 615-889-0122
ADDRESS: 25 Century Blvd. Ste. 500
 Nashville, TN 37214

Copyright © 1996 – 2018 Boson Software, LLC. All rights reserved. NetSim software and documentation are 
protected by copyright law.

NetSim Technical Support
• To review NetSim support topics, go to the NetSim Products Support Topics page  

(www.boson.com/support/netsim-support-topics).
• To submit a support ticket, go to Boson’s website (www.boson.com) > log in to your account > click the 

Support Tickets tab > start a new ticket. 

License Solutions
• Single-User License Agreement (SULA) – You can review the SULA here (www.boson.com/sula).
• License Server – For our unique license-server solutions and volume discounts, contact us at  

www.boson.com, 877-333-EXAM (3629) or support@boson.com. 

Getting Started

System Requirements
Supported operating systems: Windows 10, Windows 8, Windows 7, Windows Vista
.NET Framework: Microsoft .NET Framework Version 4.5
Processor: 1-GHz Pentium processor or equivalent (minimum); 3-GHz Pentium processor or equivalent 
(recommended)
RAM: 512 MB (minimum); 2 GB (recommended)
Hard Disk: Up to 200 MB of available space
Display: 1024 x 768, 256 colors (minimum); 1024 x 768 high color, 32-bit (recommended)
Active Internet connection

Product Activation
You must have a Boson account to download the NetSim Demo. To create a free account, visit the Boson Online 
Account page (www.boson.com/account/default.aspx) and enter a valid email address to begin creating an 
account.

You can open NetSim from the shortcut installed during the download or from the Start menu by clicking Boson 
Software > Boson NetSim 12 > Boson NetSim. If you are a student using NetSim 11 at a learning institution, 
you should launch NetSim 12 from the Start menu by clicking Boson Software > Boson NetSim 12 > Boson 

•
•
•

•
•
•
•

mailto:support@boson.com
http://www.boson.com/support/NetSim-Support-Topics.html
http://www.boson.com/support/NetSim-Support-Topics.html
www.boson.com
www.boson.com/sula
www.boson.com/sula
www.boson.com
mailto:support@boson.com
https://www.boson.com/Account/Default.aspx
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NetSim LS Client. This will enable you to configure NetSim 12 to authenticate with the Boson NetSim License 
Server.

When you first open NetSim, you will be presented with the NetSim Login dialog box. When prompted, enter 
the email address and password associated with your Boson.com account. If you have not previously created a 
Boson.com account, you will need to create one first on Boson.com. If you have any NetSim 12–related products, 
NetSim will automatically activate those items for you; otherwise, NetSim will launch in Demo mode. If you are 
using a proxy server to connect to the internet, you must configure the appropriate settings via the Settings icon  

( ) and click the Proxy Settings button.

Demo Version
In Demo mode, NetSim launches with limited commands for evaluation purposes. Within the Demo version of 
NetSim, only a few labs and commands are available. If you would like to access additional labs and commands, 
you must activate a full version of the Boson NetSim.

If you have not purchased an activation key for NetSim, you will not be able to activate the full version of NetSim. 
However, you can choose to continue in Demo mode. When you are running the Demo version, only the Demo 
labs and a limited set of commands are functional. To purchase the full version of NetSim, visit the About NetSim 
page (www.boson.com/netsim-cisco-network-simulator) of the Boson website.

Full Version
If you have already purchased a full version of NetSim 12, enter the email address and password associated with 
your Boson.com account. NetSim will automatically activate with your purchased NetSim products. Installed labs 
are made available (unlocked) depending on the products associated with your account. A small lock icon ( ) 
is displayed next to unavailable labs. To make locked labs available, you will need to purchase another product 
or enter an activation key not already associated with your account; then, more labs and a larger command set 
become available.

If you have activation keys not already associated with your Boson.com account that you would like to use 
in NetSim, click Help > Activate Keys to open the Activate Keys dialog box. Enter your additional keys as 
required. You can click the plus sign to add fields to the dialog box.

www.boson.com/netsim-cisco-network-simulator
www.boson.com/netsim-cisco-network-simulator
www.boson.com
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Begin a Lab
To begin an unlocked Boson NetSim lab, perform the following steps:

1. In the Labs pane on the left, double-click the lab you want to open. 
2. After you have loaded a lab, the Lab Instructions tab is active. Read through the lab instructions to 

familiarize yourself with the lab’s objectives.
3. From the Devices pane on the right, select the device(s) that you need to configure in order to complete 

the lab, click the Console button, and follow the steps in the lab. 

4. When you have completed the lab, click the Grade Lab icon ( ) on the toolbar to ensure that you have 
completed the lab successfully.

5. You can choose to save your configurations by selecting the appropriate Save option from the File menu. 
There is more information about saving device configurations in the New Topology section or the Quick-
Launch Toolbar section of this manual.

Menus
The menu options in NetSim 12 enable you to easily navigate through the labs, the Lab Topology and Network 
Designer, the Lab Compiler, the Consoles section, and more. These menus include the Menu Bar and the Quick-
Launch Toolbar.

Menu Bar

File Menu
The options in this menu tree enable you to open configuration files, open topology files, save configuration files, 
save topology files, import and export labs, and exit the program.

New Topology
This option opens a new topology tab.
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Open
This option enables you to select a file to open. The supported file extensions are *.top, *.lab, and *.bsn.

Save
This option enables you to save your current lab or topology and configurations. Files are saved with the *.lab 
or *.bsn extension.

Save As
This option enables you to save your current lab or topology and configurations. Files are saved with the *.lab 
or *.bsn extension.

Save All
This option enables you to save all unsaved lab, topology, and/or configurations that are currently open. Files 
are saved with the *.lab or *.bsn extension.

Package Lab
This option is primarily for License Server users and enables those users to save the current lab. This option 
adds user data so that instructors know who submitted the labs.

Import
This option imports network configurations, a previously saved lab, a previously saved lab pack, or legacy 
NetSim files.

Export
This option exports the network configurations currently running in the simulator, a lab or lab pack created 
with the Lab Compiler, or the current topology on the NetMap.

Recent Saved Labs
If you recently saved a lab, it will appear in this list. You can click a file name to open the lab. 

Recent Saved Topologies
If you recently saved a topology, it will appear in this list. You can click a file name to open the topology.

Recent Loaded Labs
If you recently loaded a lab, it will appear in this list. You can click a file name to open the lab.

Exit
This option closes the program.

Edit Menu
The options in this menu tree enable you to configure proxy settings and change your preferences.

Preferences
This option opens the Preferences dialog box, from which you can configure the appearance of NetSim, the 
user experience (including the layout and dialogs), the proxy settings, privacy settings, lab history, and cloud 
sync settings. This also enables you to restore program defaults.
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Note: Fixed-width fonts such as Courier New are highly recommended. With fixed-width fonts, output 
remains properly aligned and is easier to read and interpret.

View Menu
The options in this menu tree enable you to alter the way you view the windows and panes within NetSim.

Lab Compiler
Enable or clear this option to display or hide the features associated with the Lab Compiler.

Auto Collapse Tree
Clear this option to expand all options in the lab menu. Select this option to collapse all options in the lab 
menu.

Restore Window Layout
Use this option to reset how windows and panes are displayed back to the defaults when NetSim was 
originally installed.

Windows
Opens a sub menu to display any window or pane that you might have previously closed. 

Lab Menu
This menu tree enables you to perform all the functions you need once a lab is loaded.

Load Lab 
After you select a lab from the navigation pane, click this option to load the lab instructions, topology, and 
configurations.

Grade Lab
After you have completed a lab, click this option to verify that you have completed the lab successfully.

Lab Instructions
Click this option to open the lab instructions (if closed). You can then move the instructions to a second 
monitor or place them beside, above, or below the original NetSim window. This feature provides multimonitor 
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support so that you can view the lab document on one monitor while entering commands on a second 
monitor.

Lab Topology
Click this option to open the lab topology (if closed). You can then move the lab topology to a second 
monitor or place the lab topology, beside, above, or below the original NetSim window. This feature provides 
multimonitor support so that you can maximize the use of your computer real estate and easily view the 
topology on one monitor while entering commands on a second monitor.

Open All Devices
Click this option to open a tab in the Consoles section for every device in the network of the currently loaded 
topology.

Designer Menu
The options in this menu enable you to create a new topology and modify existing ones. You can add devices and 
connections to the topology, and you can also click and drag the devices to rearrange your simulated network.

New Topology
This option enables you to begin designing a new topology. 

Share Topology
This option enables you to share your created topology with the rest of the NetSim Community. 

Clear Topology
This option enables you to clear the topology you are creating. You will be asked to confirm that you want to 
clear the topology.

Add
This option enables you to add devices to your topology. Clicking Add > Device will open the New Device 
dialog box, from which you can choose the device you want to add. 

Compiler Menu
The options on this menu are available if the Lab Compiler is open (click View > Lab Compiler or select the Lab 
Compiler tab).The options in this menu tree enable you to create a new lab pack for personal or instructional use. 
More information can be found in the Compiling a Lab section of this manual.

New
This option enables you to select a new custom lab pack, a new lab, or a new section.

Edit
This option enables you to edit the title of previously created custom sections or lab packs and enables you to 
edit previously created custom labs.

Delete
This option deletes the selected lab pack, section, or lab. You will be asked to confirm that you want to delete 
the selected component.

Share Lab
This option allows you to share the currently selected lab with the NetSim Community.

Share Lab Pack
This option allows you to share the currently selected lab pack with the NetSim Community.
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Wizard
This option launches the Lab Compiler Wizard, which enables you to easily compile a lab pack for personal or 
instructional use.

Help Menu
The options in this menu tree enable you to find out more information about the Boson NetSim Network Simulator 
and how to find support if you need it.

User Manual
This option opens the Boson NetSim User Manual, the document you are reading now, which guides you 
through the features and functionalities of NetSim.

Support
This option displays frequently asked questions (FAQs) on the Boson NetSim support page  
(www.boson.com/support/netsim-support-topics), allows you to save your current log files in the *.zip format, 
and allows you to submit a ticket through your Boson.com account.

Activate Keys
This option opens the Activate Keys dialog box. From here, you can activate additional versions of NetSim 
not already associated with your Boson.com account.

About Boson NetSim
This option displays basic information about NetSim, including the version and company information.

Release Notes
This option displays information about the changes included in the current and previous releases of NetSim. 
The release notes are shown after the program has been updated. You can choose to not have the release 
notes appear after the program has updated by clearing the Display release notes after application 
updates check box. You can change the option at any time.

Quick-Launch Toolbar
Icons in the Quick-Launch toolbar are enabled or disabled depending on the pane in use.

New Topology

Click the New Topology icon ( ) to open the Network Designer and begin creating a topology.

Open File

Click the Open File icon ( ) to open a supported file. Supported file types are *.lab and *.bsn.

Save

Click the Save icon ( ) to save your current lab progress (*.lab) or configurations and topology (*.bsn).

Save All

Click the Save All icon ( ) to save all changes, including changes to devices in the Network Designer and 
changes to their configurations.

Grade Lab

Click the Grade Lab icon ( ) to grade the currently loaded lab.

http://www.boson.com/support/NetSim-Support-Topics.html
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Console to Device

Click the Console to Device icon ( ) to open a device from the NetMap in the Consoles section.

Zoom In

Click the Zoom In icon ( ) to increase the size of devices on the NetMap or on the active topology.

Zoom Out

Click the Zoom Out icon ( ) to decrease the size of devices on the NetMap or on the active topology.

Add New Device

Click the Add New Device icon ( ) to add a new device to the active topology on the NetMap.

Remove Device

Click the Remove Device icon ( ) to delete a selected device from the active topology on the NetMap.

Clear Topology

Click the Clear Topology icon ( ) to delete all devices and connections from the active topology on the NetMap.

Start Simulator

Click the Start Simulator icon ( ) to load the active topology into the simulator, open the Consoles section, and 
begin configuring devices. This option is disabled in Demo mode and in labs that are included in NetSim.

Stop Simulator

Click the Stop Simulator icon ( ) to stop the simulator and to reopen the NetMap, where you can reconfigure the 
devices and connections. This option is disabled in Demo mode and in labs that are included in NetSim.

Pointer

Click the Pointer icon ( ) to allow you to select and multiselect devices in your topology. You may also right-click 
devices to access additional menu items and click, hold, and move the mouse to multiselect devices.

Hand

Click the Hand icon ( ) to pan and click-move the NetMap canvas to a different location. You may also right-
click devices to access additional menu items.

Connect

Click the Connect icon ( ) to create connections between two devices. Click on a device to expand the available 
connections, select the interface to begin a connection, click on the destination device, and then select the 
interface to complete the new connection.

Edit Application Preferences

Click the Edit Application Preferences icon ( ) to configure preferences such as appearance and user 
experience.
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Open User Manual

Click the Open User Manual icon ( ) to view the Boson NetSim 12 User Manual, which is the document you are 
currently reading.

Exit Boson NetSim

Click the Exit Boson NetSim icon ( ) to exit Boson NetSim.

Move Selection Up

Click the Move Selection Up icon ( ) to move the selected lab pack, lab section, or lab up a position in the Lab 
Tree while compiling a lab pack. 

Move Selection Down

Click the Move Selection Down icon ( ) to move the selected lab pack, lab section, or lab down a position in the 
Lab Tree while compiling a lab pack.

Windows
Every window in NetSim may be closed or relocated to your preference. Each window tab features a close icon 

( ) that closes the given window. If there are unsaved changes associated with that window, such as a new 
topology, you will be prompted to save those changes before closing. The Lab Instructions window and Lab 
Topology window associated with the currently loaded lab may not be closed.

You may also reposition or undock any window in NetSim by clicking, holding the mouse button down, and 
moving the cursor to where you want to drop the window. While you are still pressing the mouse button, the 
window will detach and appear like its own stand-alone window. Any place where you wish to drop the window will 
also feature a docking hint: 

Releasing the cursor over the left icon in the hint will dock the window to the left of the hint, releasing the cursor 
over the right icon will dock the window to the right of the hint, releasing the cursor over the bottom icon will 
dock the window below the hint, releasing the cursor over the top icon will dock the window above the hint, and 
releasing the cursor over the center icon will dock the window as a tabbed item below the hint. 

As you still hold the mouse button down and move the cursor around NetSim, you will find numerous places 
to drop a given window. You may rearrange windows, pull them out, or close them entirely to customize the 
appearance to your preference. 

Home
You can open the Home window by clicking View > Windows > Home from the menu bar. There are many 
components of this panel and various features that you can access from this panel. After NetSim loads, you have 
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many options on this tab including loading a lab, checking for updates, opening the User Manual (this document), 
reading any available news, viewing saved or recent topologies or labs, and exiting NetSim. 

Saved Files
From this section, you can quickly load a saved topology, saved lab, or recent lab.

Welcome
From this, the largest section, you can load a lab, create a new topology, compile a custom lab, check for 
updates, and more. 

News
This section displays updates and special offers from the Boson website (www.boson.com). You can scroll 
through this section to see the latest news and information, and you can click more to view the related offer on 
the website. If you are not connected to the Internet, you might not see any news in this section. To see the latest 
news from Boson, make sure that you are connected to the Internet.

Community
You can open the Community window by clicking View > Windows > Community Share from the menu bar. 
This panel contains content created by other users in the NetSim community. You can use the Search box 
provided to find content by keyword; the Sort By drop-down list to sort content by average rating, newest, oldest, 
and total ratings; and the Filter By drop-down list to filter content by content type (Labs, Lab Packs, Topologies), 
your own submissions (My Submissions), and content already downloaded (Downloaded). 

www.boson.com
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Users may share with the NetSim community their own topologies, labs, and lab packs. All of the items created by 
other users are displayed on this screen. A single shared item is comprised of a title, description, and content that 
can be downloaded via the Download button. You may also rate items from one to five stars. Only items you have 
downloaded may be rated. The current rating and number of ratings is displayed for each item. 

Download
Clicking the Download button will allow you to save topologies to your local file system which you may then open 
and run in NetSim. Downloading a Lab or Lab Pack will insert the item into the Custom and Compiler Lab Tree.

Upload Topologies
To upload a topology, first open or create your custom topology in the network designer. Then click Designer > 
Share Topology. Enter the title and description then click Share and your topology will be visible to all NetSim 12 
users.

The Author field displays the name that will be visible to other users browsing content in the Boson Community. 
You may change this display name at any time by logging in to Boson.com, navigating to My Account > Login 
Settings, and updating the UserName field.

Finally, you must accept Boson’s Community Share Policy to submit your content.

Upload Labs and Lab Packs
To upload lab packs and lab topologies, open NetSim’s Lab Compiler, select one of your custom labs or lab packs 
from the Compiler Lab Tree, and click Compiler > Share Lab or Share Lab Pack. Then follow the same prompts 
to upload your content.
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Submission Approval
Once you have uploaded your topology, lab, or lab pack, your submission must be approved before it is available 
to other users via the NetSim Community. Someone at Boson will review your content and reach out to you via 
email if there are any issues. 

Lab Instructions
When you load a lab, the lab instructions window appears in the center tabbed document window section. You 
can scroll through the instructions as you work through the lab, and you can increase or decrease the size of 
the content with the zoom controls or by clicking and dragging the splitter control between the Lab Instructions 
section and the Consoles section.
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You can search the lab instructions document by clicking within the document area and pressing Ctrl+F key 
combination. You can click the down arrow on the far right of the search box to choose to match the whole word 
only or to match case. Use the left and right arrows next to the search box to find the terms you are searching for 
throughout the document.

Note: If you have selected to match case, for example, and then decide to match the whole word only and not 
case, you must click Match case again to remove it as a selected search parameter.

Lab Topology
You can view the topology of the currently loaded lab in this window. To configure a device, right-click the device 
and click Console or double-click on the device icon; the device will open in the console area below the lab 
topology. If you cannot see all the devices in the topology, you can click, hold, and drag the document out into a 
separate window. You can also use the zoom controls on the Quick-Launch toolbar or click and drag the splitter 
control between the Lab Topology section and the Consoles section to expand it.

Note: If you have a scroll button on your mouse, you can use it to increase or decrease the size of the devices 

in the Lab Topology section. You can also click and drag with the Hand tool ( ) active within the section to 
reposition the topology.
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The Lab Topology is the read-only view of the topology currently running in the simulator. If you wish to edit a 
custom topology, you can do so by creating a new topology.

Consoles Section
After you have opened a lab, you can view the device consoles and begin performing the lab steps. You will see 
the console window for each device currently opened.

From the console window, you can modify the devices and perform the steps in the lab’s instructions. The devices 
in the lab can be accessed from the View > Windows > Consoles menu or by double-clicking the device from 
the lab topology. Select a specific device to begin performing the lab steps on that device.

New Topology
You can create a new topology by clicking on the New Topology icon ( ) or by clicking File > New Topology 
from the menu bar. NetSim allows you to create a customized network topology with devices such as routers, 
switches, and PC workstations and with connections such as FastEthernet, Serial, and Frame Relay connections. 
Click and drag devices from the Recent Devices pane or the Available Devices pane to the new topology 
document. You can modify a topology by adding, editing, and deleting devices and connections; when you save 
and load a topology, the topology will appear read-only until stopped.
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Creating a New Topology
If you are creating a custom lab or want to gain extra experience with new topologies, you can use NetSim to 
create topologies with up to 200 devices. Note, however, that larger topologies might cause slow performance 
on computers that do not have sufficient processing power and memory. You can use this feature to create a 
topology file (*.bsn) that can be used in a custom lab. To learn more, see the Compiling a Lab section of this 
manual or open and perform the NetSim Topology Demo lab for a walkthrough of the feature.

To create a new simulated network topology, perform the following steps.
1. Click File > New Topology from the menu bar.
2. Add devices, including routers, switches, workstations, IP phones, and Frame Relay Switches, to the 

topology.
3. Add connections, including Serial, FastEthernet, and Frame Relay connections, between the devices you 

added to the topology.

Add Devices

Add a Router
1. Select a router from the Available Devices pane, and drag it onto the canvas where you would like the 

new device to appear.  
 
Note: You can expand the menus for the available devices by clicking the arrow next to each category.

2. In the New Device dialog box, select the desired addon (if any) for each available addon slot. 
 

3. Choose a name for the router; you can use the default name or type a name in the text box. You can 
rename a device if desired by clicking the name in the topology and modifying it.

4. Click Create.
5. Add any additional desired devices to the network.
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Add a Switch
1. Select a switch from the Available Devices pane, and drag it onto the canvas where you would like the 

new device to appear.  
 
Note: You can expand the menus for the available devices by clicking the arrow next to each category.

2. In the New Device dialog box, choose a name for the switch; you can use the default name or type 
a name in the text box. You can rename a device if desired by clicking the name in the topology and 
modifying it. 
 

3. Click Create.
4. Add any additional desired devices to the network.

Add a Workstation
1. Select the WinPC from the Available Devices pane, and drag it onto the canvas where you would like 

the new device to appear. 
2. If desired, you can choose from TFTP Server, AAA Server, and VPN Client. 

 

3. Choose a name for the workstation; you can use the default name or type a name in the text box. You can 
rename a device if desired by clicking the name in the topology and modifying it.

4. Click Create.
5. Add any additional desired devices to the network.
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Add an IP Phone
1. Select the IP Phone from the Available Devices pane, and drag it onto the canvas where you would like 

the new device to appear.
2. Choose a name for the phone; you can use the default name or type a name in the text box. You can 

rename a device if desired by clicking the name in the topology and modifying it. 
 

3. Click Create.
4. Add any additional desired devices to the network.

Add a Frame Relay Switch
1. Select Frame Relay Switch from the Available Devices pane and drag it onto the canvas where you 

would like the new device to appear.
2. Choose a name for the Frame Relay Cloud configuration; you can use the default name or type a name in 

the text box.
3. By default, Frame Relay switches in NetSim have eight ports; however, you may configure as many 

Frame Relay mapping ports as necessary. Select a port in the From Port drop-down list box, enter a 
DLCI value corresponding to the selected port in the first DLCI field, select a second port from the To 
Port drop-down list box, enter a DLCI value corresponding to the second selected port in the second 

DLCI field, and click the green Apply icon ( ). 
 

4. Repeat the previous step for every mapped value desired. It is not necessary to configure the inverse 
of any Frame Relay switch configuration mapping. The inverse Port:DLCI to Port:DLCI is automatically 
configured when you create the device.

5. Click Create.
6. Add any additional Frame Relay switches to the network.
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Connect Devices

To complete the network, choose the Connect tool from the toolbar by clicking on the Connect icon ( ). 
1. Click the first device you wish to connect.
2. In the drop-down list box that appears, select the first interface in the new connection. 

 

3. Click on another device where you want to finish the new connection.
4. In the drop-down list box that appears, select the second interface in the new connection. 

 

Note: For Serial connections, the first device selected is automatically the DCE end of the connection.

If you are creating a custom lab and compiling it for use by other NetSim users, see the Compiling a Lab 
section to continue creating the lab pack.

Save

You can save your topology by clicking the Save icon ( ) on the toolbar.

Share Topology
You can share a topology you created with the NetSim community by selecting Designer > Share Topology from 
the menu bar.
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Lab Compiler
The Lab Compiler can be used to create, edit, and delete custom lab packs that contain personalized 
documentation, topologies, and configurations. For example, you can use the Lab Compiler to create a custom 
lab pack for a classroom setting and include a custom network topology, documentation, grading functionality, and 
beginning configurations for students to practice with. The Lab Compiler is included in every version of NetSim but 
is disabled by default. To enable the Lab Compiler, go to View > Lab Compiler.

Classroom instructors commonly create custom labs that can be used both in the classroom and as homework 
assignments that follow the syllabus used in the course. Students can use homework assignments to practice the 
commands and configurations they learned in class and to prepare for the topics covered in the next day’s lecture. 
An instructor can add multiple labs to a single lab pack, covering a variety of concepts, and use custom labs to 
test the students’ knowledge about specific networking concepts.

Compiling a Lab
A completed lab must contain two files: an XPS file for the instructions and a BSN file for the completed 
configurations.

XPS File
On most Windows systems, an XPS file can be created from a word processing program by using the Print 
feature. For example, in Microsoft Word, you can create and save a Word document and then select the Print 
option. You should be able to select Microsoft XPS Document Writer from the Printer Name drop-down 
box. You should save this in a folder with the title of your lab and in a place you will remember. You can then 
save all other associated files in the same location.

BSN Topology File
A BSN file can be created within NetSim. The BSN file contains a topology and, optionally, personalized 
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configurations. To create the topology to be contained within the BSN file, see the Creating a New Topology 
section. If you save the topology without modifying the configurations in the simulator, the default settings will 
be included on all devices.

BSN Loading Configuration File
To create a loading.bsn file, you should configure the loading configurations of the devices by performing the 
following steps:
1. Ensure that the topology related to the lab is open on the NetMap.

2. Click the Start Simulator icon ( ) on the toolbar to run the topology in the simulator.
3. Enter the commands necessary to achieve the beginning configuration state you desire on each device.

4. Click the Save icon ( ) on the toolbar to save the file as loading.bsn. 
 Note: Boson recommends saving loading BSN files with the file name “loading” and saving completed  
 BSN files with the file name “completed” so that you can easily distinguish loading BSN files from  
 completed BSN files. 

BSN Completed Configuration File
The completed BSN file contains the completed configurations of all devices in your topology. To configure a 
completed BSN configuration file, perform the following steps:

1. Click the Open File icon ( ) to open the BSN topology file you previously created.

2. Click the Start Simulator icon ( ) on the toolbar to run the topology in the simulator.
3. Enter the commands necessary to achieve the final configuration state on each device. After a user  
 completes your lab according to the lab instructions you provide, the user will be able to grade the  
 commands he or she entered against the set of configurations you are currently creating.
4. Click File > Save As to save the completed.bsn file as a separate file from any other BSN files.

Creating a Custom Lab Pack
A lab pack is made up of one or more labs organized into sections. At least one section is required. To create a 
custom lab pack, you need to create a new lab pack, create a new section, and then compile a new lab. You can 
either use the Lab Compiler Wizard or create a lab pack manually. 

Using the Lab Compiler Wizard to Create a Lab Pack 
1. Click the Launch Wizard button at the bottom of the Lab Compiler pane.
2. Enter a title in the Lab Pack Title field, and click Next.
3. Enter a section title in the Section Title field, enter a lab title in the Lab Title field, and click Next.
4. Click the Browse buttons, and select the appropriate lab guide documentation (*.xps) and completed  
 network files (*.bsn) you created and stored on your computer. Click Next. 
 Note: To learn how to create completed network files (*.bsn), see the BSN Completed Configuration File  
 section in this manual.
5. If desired, select a loading file (*.bsn) and click Next.
6. If desired, type a description and click Next.
7. Click Finish to return to the Lab Compiler main page.

After you create a lab pack by using the Lab Compiler Wizard, you should see the lab in the navigation pane. You 
can double-click a lab to open it, or you can click New Section or New Lab to continue creating the lab pack. 
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Manually Creating a Lab Pack
1. Click View > Lab Compiler.
2. Click New Lab Pack in the Getting Started section.
3. Enter a name for the lab pack. This is a lab pack title that will be displayed in the tree.
4. Click Save. 
 

Adding a Section to a Lab Pack
1. In the custom lab tree on the left, select the title of the lab pack where you want to add a new section.
2. Click New Section in the Getting Started section.
3. Enter a name for the section. This is a section title that will be displayed in the tree.
4. Click Save. 
 

Adding a Lab to a Lab Pack Section
1. In the custom lab tree on the left, select the title of the section where you want to add a new lab.
2. Click New Lab in the Getting Started section.
3. Enter a name for the lab. This is a lab title that will be displayed in the tree.
4. Add a completed Boson Network file (.bsn).
5. Add a document. The only document files accepted are XPS documents (.xps).
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You may optionally add a description and a loading BSN file to the lab. If neither file is desired, proceed to 
step 9.

6. Click Optional Fields in the Lab section.
7. Enter a description for the lab. A description is displayed for every lab underneath the Lab Tree.
8. Add a loading Boson Network file (.bsn). The topology in the specified loading file must match the  
 topology in the completed file from step 4. You will receive an error message if the topologies do not  
 match.
9. Click Save. 
 

10. To add additional labs to the lab pack section, repeat steps 1 through 9 until the lab pack section is  
 complete.
11. You can edit, add, delete, import, and export lab packs, sections, and labs with the options on the  
 Compiler menu and on the Quick-Launch toolbar.

Sharing a Lab
You can share your user-created lab with the NetSim community by selecting the lab in the Compiler Lab Tree 
pane and selecting Compiler > Share Lab from the menu bar.

Sharing a Lab Pack
You can share your user-created lab pack with the NetSim community by selecting the lab pack in the Compiler 
Lab Tree pane and selecting Compiler > Share Lab Pack from the menu bar.
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Panes
Similar to windows, each pane in NetSim may also be hidden, set to auto collapse, docked in a different location, 
or pulled out of the application and displayed as a stand-alone pane. Click and hold the pane title to preview 

where you can arrange each pane. Clicking the Window Position icon ( ) will expand options to float, dock, 

dock as a tabbed document, auto hide, and hide. Clicking the Auto Hide Pin icon ( ) will toggle auto hide on and 

off. Clicking the Close icon ( ) will hide the window.

Labs
You can open the Labs pane by clicking View > Windows > Labs on the menu bar. This pane contains a list of 
labs you can load, a text box to enter text and search the available labs for keywords, and a drop-down list box to 
select different Lab trees.

Select Lab Tree
There are several lab trees available to you. The default selection is Standard. Standard labs are labs written 
with the intent to give students thorough practice with commands found in Cisco’s Official Student Lab Guide. 
Courseware labs accompany Boson’s Courseware product and will be locked unless you have purchased 
activation keys for the specific labs. Courseware labs are available for purchase on the Courseware page of 
the Boson.com website (www.boson.com/courseware-cisco-curriculum). These labs, similar to the Standard 
labs, have been written with the intent to give students thorough practive with the commands and objectives 
that students are expected to know for the relate Cisco exams. The Custom lab tree displays labs that you 
create, download from the NetSim Community, or import from another source. To learn how to compile your 
own labs using NetSim, see the Compiling a Lab section of this manual.

Search Labs
You can use the Search Labs section to search for a specific term within a lab description. You can search 
throughout all the available labs. For example, if you want to test your Network Address Translation (NAT) 
skills on labs dealing with NAT, you could type NAT in the search box and press the Enter key. You will see 
labs addressing NAT from the ICND1 Stand-Alone, Sequential, and Scenario lab packs, among others. Note 
that although the search returned results from additional lab packs, only labs from the currently activated 
version of NetSim will be available.

Available Labs
There are over 480 labs in NetSim 12, and these labs are arranged in specific categories. The lab packs are 
Demo, ICND1, ICND2, ROUTE, SWITCH, TSHOOT, and Supplemental. You can single-click on a lab to view 
the Lab Preview screen. To open and load a lab, double-click the lab or select the lab and click Lab > Load 
Lab. You can expand or collapse the menu items by clicking the arrow next to each category.

http://www.boson.com/courseware-cisco-curriculum
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Available Devices
The Available Devices pane displays all devices you can add to a new topology. Click and drag the desired 
device to the New Topology canvas, and the New Device dialog box will appear. The new device is added where 
your cursor was positioned when you released the mouse button.
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Compiler Lab Tree
The Compiler Lab Tree pane displays any lab packs that you have created by using the Lab Compiler.

Connections
The Connections pane displays all of the configured connections in the currently active topology or Lab Topology 
document. You can right-click on a connection within this pane to access a sub menu to remove the connection. 
You cannot remove a connection using this window if the active topology document is currently running in the 
simulator.

Devices
The Devices pane displays all of the devices in the currently active topology or Lab Topology document. You 
can right-click on a device in the Devices pane to access that device’s sub menu. The sub menu permits you to 
delete a device if the currently topology document is not running or console to the device if the current topology 
document is running. You may also select a device and click the Console button to access a device’s console 
while a topology is running.

Recent Devices
The Recent Devices pane displays all of the devices you have recently added to a new topology. The most 
recent device is displayed at the top of the list. When the New Topology pane is open, you can add a recent 
device to a new topology by clicking on the recent device, holding the mouse button down, moving the cursor to 
the canvas, and releasing the mouse button. A new device with the same settings as the recent device selected is 
added to the new topology where the cursor was located when you released the mouse button.
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Settings
The Settings pane makes available several topology document settings features. You can enable or disable 
labels, enable or disable snap to grid, and enable or disable notes.

Troubleshooting

Some of my labs have locks next to them, and I can’t work through 
them
The activation key you purchased unlocks the labs and the commands that are included with that level of NetSim 
12. If a lab is unavailable with the activation key you purchased, you will see a small lock icon ( ) next to that lab. 
You can purchase higher-level activation keys, which will allow you to work through additional labs plus all labs 
unlocked by lower-level activation keys. All Demo, CCENT, CCNA, and CCNP labs are unlocked when a CCNP-
level activation key is used. Additional labs are unlocked with the appropriate activation key; if you have questions 
about locked labs, please contact support@boson.com. Only the Demo labs are available without an activation 
key.

The Compiler Lab Tree and Custom Lab Tree are empty
You will see labs on the Compiler lab tree or Custom lab tree only if you have imported labs you received from 
another NetSim user or from an instructor or if you have created your own labs. To find out how to import labs or 
how to create your own labs, see the Compiling a Lab section of this manual.

mailto:support@boson.com
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Can I use key combinations as shortcuts?
The following table contains various shortcut key combinations you can use in NetSim:

Function Key
General Application Shortcuts

New lab Ctrl+N
Open lab Ctrl+O
Save lab Ctrl+S
Grade lab Ctrl+G
Help Ctrl+F1
Close Alt+F4
Show/Hide Menu Bar Tilde key (~)

NetMap and Designer Shortcuts
Increase zoom Ctrl+Plus Sign (+)
Decrease zoom Ctrl+Minus Sign (-)

Console Shortcuts
Move to beginning of line Ctrl+A
Move to end of the line Ctrl+E
Move back one character Ctrl+B
Move forward one character Ctrl+F
Next command Ctrl+N
Previous command Ctrl+P
Break Ctrl+C
Move back 1 device Ctrl+Shift+Tab, or Ctrl+Comma
Move forward 1 device Ctrl+Tab, or Ctrl+Period
Jump to Device 1 F1
Jump to Device 2 F2
Jump to Device 3 F3
Jump to Device 4 F4
Jump to Device 5 F5
Jump to Device 6 F6
Jump to Device 7 F7
Jump to Device 8 F8
Jump to Device 9 F9
Jump to Device 10 F10
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